码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ3471---Most Powerful(状压dp)

时间:2015-04-24 19:14:37      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:状压dp

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, … , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22

水题, dp[i] 表示存在着的原子的状态为i时,放出的最大的能量
倒过来枚举状态就行了,最后只剩下1个原子

/*************************************************************************
  > File Name: ZOJ3471.cpp
  > Author: ALex
  > Mail: zchao1995@gmail.com 
  > Created Time: 2015年04月24日 星期五 16时40分03秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

LL dp[1050];
LL A[15][15];

int main() {
    int n;
    while (cin >> n) {
        if (!n) {
            break;
        }
        memset(dp, 0, sizeof(dp));
        for (int i = 0; i < n; ++i) {
            for (int j = 0; j < n; ++j) {
                cin >> A[i][j];
            }
        }
        for (int i = (1 << n) - 1; i >= 1; --i) {
            for (int j = 0; j < n; ++j) {
                if (i & (1 << j)) {
                    for (int k = 0; k < n; ++k) {
                        if (j == k) {
                            continue;
                        }
                        if (i & (1 << k)) {
                            dp[i ^ (1 << k)] = max(dp[i ^ (1 << k)], dp[i] + A[j][k]);
                        }
                    }
                }
            }
        }
        LL ans = 0;
        for (int i = 0; i < n; ++i) {
            ans = max(ans, dp[1 << i]);
        }
        cout << ans << endl;
    }
    return 0;
}

ZOJ3471---Most Powerful(状压dp)

标签:状压dp

原文地址:http://blog.csdn.net/guard_mine/article/details/45248687

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!