码迷,mamicode.com
首页 > 其他好文 > 详细

整除的尾数

时间:2015-04-24 22:48:39      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27386    Accepted Submission(s): 11588


Problem Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
 

Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
 

Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
 

Sample Input
200 40 1992 95 0 0
 

Sample Output
00 40 80 15
 

#include<stdio.h>
main()
{
      int a,b,j,i,k,c,s[100];
     while(scanf("%d%d",&a,&b)!=EOF)
     { 
       if(a==0&&b==0)
        break;                            
      j=0;
      c=a*100;
      for(i=0;i<100;i++)
         if((c+i)%b==0)
         {
           s[j]=i;
           j++;
          }
         for(k=0;k<j-1;k++)
         printf("%02d ",s[k]);
         printf("%02d\n",s[k]);
     } 
      return 0;
      }

整除的尾数

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/45251991

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!