码迷,mamicode.com
首页 > 其他好文 > 详细

poj1742coins

时间:2015-04-25 01:33:23      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=1742

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch.  You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
题意:给定价值为Ai的硬币个数为Ci个,用这些硬币进行组合,能组成在m之内的数的个数。
这个是动态规划,但是我第一感觉这是一个母函数的..后来想想只是母函数的话,复杂度就过高了
然后我们可以用dp来记录更新dp[i]是否可以可以组合得到i,能的话,就加1,枚举j<=m,sum[]记录的是由价值为Ai的硬币数得到价值为j用的个数,具体做就是sum[j]=sum[j-Ai]+1;
#include <stdio.h>
#include <algorithm>
#include <string.h>
int dp[100005];//dp表示的是价值为j的可以得到与否
int sum[100005];//sum[j]=sum[j-val]+1;得到价值为j的用了价值为val的多少个
int val[105],cal[105];
int main()
{
    int i,j,k,n,m;
    while(scanf("%d%d",&n,&m)&&n|m)
    {
        for(i = 1;i<=n;i++)
        scanf("%d",&val[i]);
        for(i = 1;i<=n;i++)
        scanf("%d",&cal[i]);
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        int ans = 0;
        for(i=1;i<=n;i++)
        {
            memset(sum,0,sizeof(sum));
            for(j = val[i];j<=m;j++)//j每次从val[i]开始
            {
                if(!dp[j] && dp[j-val[i]] && sum[j-val[i]]<cal[i])
                {
                    dp[j] = 1;
                    sum[j] = sum[j-val[i]]+1;
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

poj1742coins

标签:

原文地址:http://www.cnblogs.com/osiris53719/p/4455093.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!