码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3466——背包DP——Proud Merchants

时间:2015-04-25 11:54:57      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:

Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more. 
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 
If he had M units of money, what’s the maximum value iSea could get? 

 

Input

There are several test cases in the input. 

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. 

The input terminates by end of file marker. 

 

Output

For each test case, output one integer, indicating maximum value iSea could get. 

 

Sample Input

2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output

5 11
 大意:考虑到了要排序..按照q-p进行排序,从小到大,q-p即下面一个物品的最少的所需要的钱,贪心的思想,然后01背包
技术分享
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[5500];
int n,m;
struct edge{
    int p;
    int q;
    int v;
}a[5500];
bool cmp(edge i, edge j){
    return i.q - i.p <j.q - j.p;
}
int main()
{
    while(~scanf("%d%d",&n,&m)){
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= n ; i++)
            scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v);
        sort(a+1,a+n+1,cmp);
        for(int i = 1 ; i <= n ; i++){
            for(int j = m; j >= a[i].q ;j--){
                dp[j] = max(dp[j],dp[j-a[i].p]+a[i].v);
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}
View Code

 

HDU3466——背包DP——Proud Merchants

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4455493.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!