码迷,mamicode.com
首页 > 其他好文 > 详细

Oulipo

时间:2015-04-25 16:45:37      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:

Oulipo
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

思路:
   KMP算法的实现就能AC,朴素匹配算法会超时用不得。
我的代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char a[10010],b[1000010];
int ne[10010];
void fun(char *p,int L)//找出子串的相同的前缀与后缀,用ne数组储存起来
{
	int i,j;
	i=0;j=-1;//大话数据结构的是从ne【1】开始的,但是我不会忽略ne【0】输入一个字符串
	ne[0]=-1;
	while (i<L)
	{
		if (j==-1||p[i]==p[j])
		{
			i++;j++;
			ne[i]=j;
		}
		else
		{
			j=ne[j];
		}
	}
}
int main()
{
	int n,i,j,k,lena,lenb,count;
	scanf("%d",&n);
	while (n--)
	{
		scanf("%s %s",&a,&b);
		lena=strlen(a);
		fun(a,lena);
		lenb=strlen(b);
		count=0;
		i=-1;j=-1;
		while (i<lenb)//这里与寻找ne数组很像
		{
			if (j==-1||a[j]==b[i])
			{
				i++;
				j++;
			}
			else
			{
				j=ne[j];
			}
			if (j==lena)
			{
				count++;
				j=ne[j];
			}
		}
		printf("%d\n",count);
	}
	return 0;
}


Oulipo

标签:

原文地址:http://blog.csdn.net/zsc2014030403015/article/details/45270469

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!