码迷,mamicode.com
首页 > 其他好文 > 详细

12th浙江省省赛 B题 Beauty of Array

时间:2015-04-25 21:14:48      阅读:220      评论:0      收藏:0      [点我收藏+]

标签:acm省赛

Beauty of Array

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38
题意:自译吧。
我当时想的是树状数字 学长想的是线段数 (都没想通如何去重复的)
队友用动态 秒过了
思路:

2 3 3 2
:
2 3 3 2
   3 3 2
      3 2
          2
 每次减去之前 
#include<bits/stdc++.h>
using namespace std;
long long sum[1000010];
long long a[100010];
long long b[100010];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(sum,0,sizeof(sum));
        long long n;
        scanf("%lld",&n);
        b[0]=0;
        a[0]=0;
        for(long long i=1;i<=n;i++)
        {
            long long shu;
            scanf("%lld",&shu);
            b[i]=b[i-1]+(i-sum[shu])*shu;
            a[i]=a[i-1]+b[i];
            sum[shu]=i;
        }
        cout<<a[n]<<endl;
    }
}


12th浙江省省赛 B题 Beauty of Array

标签:acm省赛

原文地址:http://blog.csdn.net/u012349696/article/details/45274087

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!