码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3249 Test for Job (记忆化搜索 好题)

时间:2015-04-25 21:16:45      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:poj   记忆化搜索   

Test for Job
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9512   Accepted: 2178

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It‘s hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases.
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads.
The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ |Vi| ≤ 20000)
The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

技术分享

题目链接:http://poj.org/problem?id=3249

题目大意:给多棵树,求从根到叶子的最大值

题目分析:泪奔,和南邮2015校赛D类似,还比那个难,本题必须用记忆化搜索做,而且不是一颗树,先用ind数组统计根的个数及入度,然后从每个根出发记忆化搜索整棵树得到一个最大值,注意这里的边权可能为负,没注意wa了两发


#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
int const MAX = 1e5 + 5;
int const INF = 2147483640;
int n, m;
int dp[MAX], val[MAX], ind[MAX];
vector <int> vt[MAX];

int DFS(int x)
{
    if(dp[x])
        return dp[x];
    int sz = vt[x].size();
    if(sz == 0)
        return val[x];
    int tmp = -INF;
    for(int i = 0; i < sz; i++)
    {
        int u = vt[x][i];
        tmp = max(tmp, val[x] + DFS(u));
    }
    return dp[x] = tmp;
}

int main()
{
    while(scanf("%d %d", &n, &m) != EOF)
    {
        for(int i = 1; i <= n; i++)
            vt[i].clear();
        memset(ind, 0, sizeof(ind));
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++)
            scanf("%d", &val[i]);
        for(int i = 0; i < m; i++)
        {
            int u, v;
            scanf("%d %d", &u, &v);
            vt[u].push_back(v);
            ind[v]++;
        }
        int ans = -INF;
        for(int i = 1; i <= n; i++)
            if(!ind[i])
                ans = max(ans, DFS(i));
        printf("%d\n", ans);
    }
}





POJ 3249 Test for Job (记忆化搜索 好题)

标签:poj   记忆化搜索   

原文地址:http://blog.csdn.net/tc_to_top/article/details/45273833

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!