标签:poj 记忆化搜索
Pascal‘s Travels
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 5328 |
|
Accepted: 2396 |
Description
An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board.
The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom.
Note that a 0 is a dead end which prevents any further progress.
Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.
|
|
Figure 1
|
Figure 2
|
Input
The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34,
which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.
Output
The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 263
paths for any board.
Sample Input
4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1
Sample Output
3
0
7
Hint
Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as long values in Java or long long values using the contest‘s C/C++ compilers.
Source
Mid-Central USA 2005
题目链接:http://poj.org/problem?id=2704
题目大意:从左上角开始到右下角,每次只能向右或者向下,并且只能走当前位置点数的步数,求从起点到终点有多少种走法
题目分析:很简单的记忆化搜索,dp[i][j]记录点(i,j)到终点的方案数,注意要用unsigned long long,long long都跪了
#include <cstdio>
#include <cstring>
#define ull unsigned long long
int const MAX = 40;
int map[MAX][MAX];
ull dp[MAX][MAX];
int n;
ull DFS(int x, int y)
{
if(dp[x][y])
return dp[x][y];
if(x > n || y > n)
return 0;
if(x == n && y == n)
return 1;
if(map[x][y] == 0)
return dp[x][y] = 0;
ull tmp = 0;
tmp += DFS(x + map[x][y], y);
tmp += DFS(x, y + map[x][y]);
return dp[x][y] = tmp;
}
int main()
{
while(scanf("%d", &n) != EOF && n != -1)
{
char s[100];
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= n; i++)
{
scanf("%s", s + 1);
for(int j = 1; j <= n; j++)
map[i][j] = s[j] - '0';
}
printf("%llu\n", DFS(1, 1));
}
}
POJ 2704 Pascal's Travels (基础记忆化搜索)
标签:poj 记忆化搜索
原文地址:http://blog.csdn.net/tc_to_top/article/details/45274361