码迷,mamicode.com
首页 > 其他好文 > 详细

Ace of Aces

时间:2015-04-26 09:29:02      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:

Ace of Aces

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output

2
Nobody
998
我们队一起做的。应该可以看懂。。
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct ID
{
	int count;
	int id;
};
int cmp(ID a,ID b)
{
	return a.count<b.count;
}
int main()
{
	ID b[1100];
	int a[1100],T,g,n,i,count1,k;
	while(scanf("%d",&T)!=EOF)
	{
		while(T--)
		{
			k=0;
			g=0;
			cin>>n;
			for(i=0;i<n;i++)
				cin>>a[i];
			sort(a,a+n);
			for(i=0;i<n;i++)
			{
				count1=1;
				while(i<n-1 &&a[i]==a[i+1])
				{
                   count1++;
				   i++;
				}
				b[k++].count=count1;
				b[g++].id=a[i];
			}
			sort(b,b+k,cmp);
            if(b[k-1].count==b[k-2].count)
				cout<<"Nobody"<<endl;
			else
				cout<<b[k-1].id<<endl;
		}
	}
	return 0;
}

Ace of Aces

标签:

原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/45273611

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!