码迷,mamicode.com
首页 > 其他好文 > 详细

Balloon Comes! hdu(小数位数处理)

时间:2015-04-26 12:09:56      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:

Balloon Comes! 
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)  
Total Submission(s): 5402 Accepted Submission(s): 1722  

 
Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result. 
Is it very easy? 
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!

 
 
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator. 

 
 
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

 
 
Sample Input
4
+ 1 2
- 1 2
* 1 2
/ 1 2 
 
Sample Output
3
-1
2
0.50 
package ACM1;

import java.math.RoundingMode;
import java.text.DecimalFormat;
import java.util.Scanner;

public class hdu1 {
    public static void main(String[]args)
    {
        Scanner scanner = new Scanner(System.in);
        int n = scanner.nextInt();
        
        for(int i=0;i<n;i++)
        {   
            
            String a = scanner.next();
            int b = scanner.nextInt();
            int c = scanner.nextInt();
            //double result = (double)b/(double)c;
            if(a.charAt(0)==‘+‘)
                System.out.println((b+c));
            else if(a.charAt(0)==‘-‘)
                System.out.println((b-c));
            else if(a.charAt(0)==‘*‘)
                System.out.println((b*c));
            else
                {
                    if(b%c==0)
                        System.out.println((b/c));
                    else
                    {
                        DecimalFormat dc = new DecimalFormat("0.00");
                        //dc.setMaximumFractionDigits(2);
                        //dc.setGroupingSize(0);
                        //dc.setRoundingMode(RoundingMode.FLOOR);
                        //System.out.println(dc.format(b/(1.0*c)));//我不明白为什么这个样子不对
                        System.out.format("%.2f",(b/(1.0*c)) ).println();//为什么这个样子对
                        
                        
                    }
                
                
                }
                
            }
            
            
        }
        
    }

 

Balloon Comes! hdu(小数位数处理)

标签:

原文地址:http://www.cnblogs.com/mmlovejj/p/4457502.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!