码迷,mamicode.com
首页 > 其他好文 > 详细

Convert QWERTY to Dvorak

时间:2015-04-26 12:29:03      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:浙江省赛

Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken Caps Lock key, so Edward never presses the broken Caps Lock key. Luckily, all the other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

The QWERTY Layout and the Dvorak Layout are in the following:

技术分享
The QWERTY Layout

技术分享
The Dvorak Layout

Input

A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

Output

The Dvorak document.

Sample Input

Jgw Gqm Andpw a H.soav Patsfk f;doe
Nfk Gq.d slpt a X,dokt vdtnsaohe
Kjd yspps,glu pgld; aod yso kd;kgluZ
1234567890
`~!@#$%^&*()}"‘]_+-=ZQqWEwe{[\|
ANIHDYf.,bt/
ABCDEFuvwxyz

Sample Output

Hi, I‘m Abel, a Dvorak Layout user.
But I‘ve only a Qwerty keyboard.
The following lines are for testing:
1234567890
`~!@#$%^&*()+_-={}[]:"‘<>,.?/\|
ABCDEFuvwxyz
AXJE>Ugk,qf;


题意:输入第一个表的字符,输出对应下表的字符
思路:打表
#include<stdio.h>
#include<string.h>
char str[96][2]={ 
{'-','['},{'_','{'},{'+','}'},{'=',']'},{'Q','"'},
{'q','\''},{'W','<'},{'w',','},{'E','>'},{'e','.'},
{'R','P'},{'r','p'},{'T','Y'},{'t','y'},{'Y','F'},
{'y','f'},{'U','G'},{'u','g'},{'I','C'},{'i','c'},
{'O','R'},{'o','r'},{'P','L'},{'p','l'},{'{','?'},
{'[','/'},{'}','+'},{']','='},{'S','O'},{'s','o'},
{'D','E'},{'d','e'},{'F','U'},{'f','u'},{'G','I'},
{'g','i'},{'H','D'},{'h','d'},{'J','H'},{'j','h'},
{'K','T'},{'k','t'},{'L','N'},{'l','n'},{':','S'},
{';','s'},{'"','_'},{'\'','-'},{'Z',':'},{'z',';'},
{'X','Q'},{'x','q'},{'C','J'},{'c','j'},{'V','K'},
{'v','k'},{'B','X'},{'b','x'},{'N','B'},{'n','b'},
{'<','W'},{',','w'},{'>','V'},{'.','v'},{'?','Z'},
{'/','z'},{'~','~'},{'`','`'},{'!','!'},{'1','1'},
{'@','@'},{'2','2'},{'#','#'},{'3','3'},{'$','$'},
{'4','4'},{'%','%'},{'5','5'},{'^','^'},{'6','6'},
{'&','&'},{'7','7'},{'*','*'},{'8','8'},{'(','('},
{'9','9'},{')',')'},{'0','0'},{'M','M'},{'m','m'},
{'A','A'},{'a','a'}, {'|','|'},{'\\','\\'},{' ',' '}            
             };

int main()
{
  char s[102500];
  int i,j;
  while(gets(s))
  {
    int len=strlen(s);              
     for(i=0;i<len;i++)
     {
       for(j=0;j<96;j++)
       if(s[i]==str[j][0]) printf("%c",str[j][1]);                  
     }
     printf("\n");
  }    
return 0;
}



Convert QWERTY to Dvorak

标签:浙江省赛

原文地址:http://blog.csdn.net/u012346225/article/details/45286621

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!