码迷,mamicode.com
首页 > 其他好文 > 详细

友元函数

时间:2015-04-26 22:29:19      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:

Description
定义Boat与Car两个类,二者都有weight属性,定义二者的一个友元函数totalWeight(),计算二者的重量和。
Input
多组数据。每组包含2个整数mn,分别表示BoatCat的重量。
Output
BoatCat的重量之和。
Sample Input
4 5

6 8

Sample Output

9

14

 

Hint
知识点:友元函数

#include <iostream>
#include<cmath>
using namespace std;
class Car;
class Boat
{
public:
   int weight;
   friend int totalWeight(Boat &boat, Car &car);
   Boat(int a):weight(a){}
};

class Car
{
public:
   int weight;
   friend int totalWeight(Boat &boat, Car &car);
   Car(int a):weight(a){}
};

int totalWeight(Boat &boat, Car &car)
{
   return boat.weight+car.weight;
}
int main()
{
   int boatw,carw;
   while(cin>>boatw>>carw)
   {
        Boat boat(boatw);Car car(carw);
        cout<<totalWeight(boat,car)<<endl;
   }
   return 0;    `
}

友元函数

标签:

原文地址:http://www.cnblogs.com/zeross/p/4458472.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!