码迷,mamicode.com
首页 > 其他好文 > 详细

(最大团) poj 3692

时间:2015-04-27 19:58:02      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:

L - Kindergarten
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
GB (1 ≤ GB ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

题意:

给出女生人数 G 男生人数 B 和 男女认识的关系数 M

接下来 M 行..

a b 表示女生 a 和男生 b 认识..

当G B M都等于0的时候表示输入结束..

 

输出可以找出多少个人是互相认识的..

P.S. 男生们都互相认识了~女生们也都互相认识了..

分析:

题目是让求最大团,显然 最大团等于补图的最大独立集。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
int n,m,k;
int mp[210][210],link[210],mark[210];
bool dfs(int x)
{
    for(int i=1;i<=m;i++)
    {
        if(mark[i]==-1&&mp[x][i])
        {
            mark[i]=1;
            if(link[i]==-1||dfs(link[i]))
            {
                link[i]=x;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int x,y,cas=1;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        if(n==0&&m==0&&k==0)
            break;
        int ans=0;
        memset(mp,1,sizeof(mp));
        memset(link,-1,sizeof(link));
        for(int i=0;i<k;i++)
        {
            scanf("%d%d",&x,&y);
            mp[x][y]=0;
        }
        for(int i=1;i<=n;i++)
        {
            memset(mark,-1,sizeof(mark));
            if(dfs(i))
                ans++;
        }
        printf("Case %d: ",cas);
        printf("%d\n",n+m-ans);
        cas++;
    }
    return 0;
}

  

(最大团) poj 3692

标签:

原文地址:http://www.cnblogs.com/water-full/p/4460919.html

(1)
(1)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!