码迷,mamicode.com
首页 > 其他好文 > 详细

poj2155Matrix

时间:2015-04-27 21:46:24      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 20161   Accepted: 7532

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

加值的时候直接加一个块。

 

查询的时候把这个点以及和这个点相关的都累加起来。


#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
using namespace std;
const int N=1010;
int ir[N],ic[N];
struct Nr
{
	int l,r;
	struct Nc
	{
		int l,r,val;
	}nc[N<<2];
	void build(int l,int r,int k)
	{
		nc[k].l=l;
		nc[k].r=r;
		nc[k].val=0;
		if(l==r)
		{
			ic[l]=k;
			return;
		}
		int m=(l+r)>>1;
		build(l,m,k<<1);
		build(m+1,r,k<<1|1);
	}
	void add(int l,int r,int k)
	{
		if(nc[k].l==l&&nc[k].r==r)
		{
			nc[k].val++;
			return;
		}
		int m=nc[k].l+nc[k].r>>1;
		if(r<=m)
			add(l,r,k<<1);
		else if(l>m)
			add(l,r,k<<1|1);
		else
		{
			add(l,m,k<<1);
			add(m+1,r,k<<1|1);
		}
	}
}nr[N<<2];
void build(int l,int r,int n,int k)
{
	nr[k].l=l;
	nr[k].r=r;
	nr[k].build(1,n,1);
	if(l==r)
	{
		ir[l]=k;
		return;
	}
	int m=(l+r)>>1;
	build(l,m,n,k<<1);
	build(m+1,r,n,k<<1|1);
}
void add(int l,int r,int l1,int r1,int k)
{
	if(nr[k].l==l&&nr[k].r==r)
	{
		nr[k].add(l1,r1,1);
		return;
	}
	int m=nr[k].l+nr[k].r>>1;
	if(r<=m)
		add(l,r,l1,r1,k<<1);
	else if(l>m)
		add(l,r,l1,r1,k<<1|1);
	else
	{
		add(l,m,l1,r1,k<<1);
		add(m+1,r,l1,r1,k<<1|1);
	}
}
int seek(int r,int c)
{
	int ans=0;
	for(int i=ir[r];i>0;i>>=1)
		for(int j=ic[c];j>0;j>>=1)
			ans+=nr[i].nc[j].val;
	return ans;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		build(1,n,n,1);
		while(m--)
		{
			char s[100];
			scanf("%s",s);
			if(s[0]=='C')
			{
				int r1,c1,r2,c2;
				scanf("%d%d%d%d",&r1,&c1,&r2,&c2);
				add(r1,r2,c1,c2,1);
			}
			else
			{
				int r,c;
				scanf("%d%d",&r,&c);
				printf("%d\n",seek(r,c)%2);
			}
		}
		puts("");
	}
}



poj2155Matrix

标签:

原文地址:http://blog.csdn.net/stl112514/article/details/45315785

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!