码迷,mamicode.com
首页 > 其他好文 > 详细

SDUT 2044 Number Sequence(循环)

时间:2015-04-27 21:51:32      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

Number Sequence

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

A number sequence is defined as follows: 

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

Given A, B, and n, you are to calculate the value of f(n).

输入

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

输出

For each test case, print the value of f(n) on a single line.

示例输入

1 1 3
1 2 10
0 0 0

示例输出

2
5

提示

知识扩展:本类算法在数字医疗、移动证券、手机彩票、益智类解谜类游戏软件中会经常采用。

来源

 

示例程序

 


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;


int k[100000001];

int main()
{
    int a,b,n;
    while(scanf("%d%d%d",&a,&b,&n)!=EOF)
    {
        int x=100000001;
        if(a==0 && b==0 && n==0)
        {
            break;
        }
        k[1]=1;
        k[2]=1;
        for(int i=3; i<=n; i++)
        {
            k[i]=(a*k[i-1]+b*k[i-2])%7;
            if(k[i-1]==1 && k[i]==1)
            {
                x=i-2;
                break;
            }
        }
        printf("%d\n",k[(n)%x]);
    }
    return 0;
}

 


SDUT 2044 Number Sequence(循环)

标签:

原文地址:http://blog.csdn.net/yeguxin/article/details/45315469

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!