码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5210 Delete(set)

时间:2015-04-28 09:48:25      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:c

Delete

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 209    Accepted Submission(s): 142


Problem Description
WLD likes playing with numbers. One day he is playing with N技术分享 integers. He wants to delete K技术分享 integers from them. He likes diversity, so he wants to keep the kinds of different integers as many as possible after the deletion. But he is busy pushing, can you help him?
 

Input
There are Multiple Cases. (At MOST 100技术分享)

For each case:

The first line contains one integer N(0<N100)技术分享.

The second line contains N技术分享 integers a1,a2,...,aN(1aiN)技术分享, denoting the integers WLD plays with.

The third line contains one integer K(0K<N)技术分享.
 

Output
For each case:

Print one integer. It denotes the maximum of different numbers remain after the deletion.
 

Sample Input
4 1 3 1 2 1
 

Sample Output
3
Hint
if WLD deletes a 3, the numbers remain is [1,1,2],he‘ll get 2 different numbers. if WLD deletes a 2, the numbers remain is [1,1,3],he‘ll get 2 different numbers. if WLD deletes a 1, the numbers remain is [1,2,3],he‘ll get 3 different numbers.
题意:
从n个数中删k个数,求剩下的数中最多有多少个不同的数
代码:
#include<cstdio>
#include<set>
using namespace std;

int a[105];

int main()
{
    set<int> st;
    int n;
    while(scanf("%d",&n)==1)
    {
        st.clear();
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            st.insert(a[i]);
        }
        int cnt=n-st.size();
        int k;
        scanf("%d",&k);
        if(k<=cnt)
            printf("%d\n",st.size());
        else
            printf("%d\n",st.size()-k+cnt);
    }
    return 0;
}


hdu 5210 Delete(set)

标签:c

原文地址:http://blog.csdn.net/xky1306102chenhong/article/details/45320611

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!