码迷,mamicode.com
首页 > 其他好文 > 详细

多重背包——POJ 1742

时间:2015-04-28 09:51:16      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:

对应POJ题目:点击打开链接

Coins
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 30387   Accepted: 10325

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题意:给出n个面额的硬币以及他们的数量,求能组合成多少种面额不同钱。


思路:多重背包。用dp[i]表示能否组成面额为i的钱,是1则可以,0则不可以。用一个数组记录某个体积使用的次数。


#include<cstdio>
#include<iomanip>
#include<iostream>
#include<cstring>
using namespace std;
const int MAXN=100005;
int a[105]; //价值
int b[105]; //数量
int w[MAXN]; //w[i]表示体积为i的模价值的同余类所用的数量
bool dp[MAXN];

int main()
{
	//freopen("in.txt","r",stdin);
	int N,V;
	while(scanf("%d%d",&N,&V), N+V)
	{
		memset(dp,0,sizeof(dp));
		int i,j;
		for(i=1; i<=N; i++)
			scanf("%d",&a[i]);
		for(i=1; i<=N; i++)
			scanf("%d",&b[i]);
		int sum=0;
		dp[0]=1;
		for(i=1; i<=N; i++){
			memset(w,0,sizeof(w));
			for(j=a[i]; j<=V; j++){
				if(!dp[j] && dp[j-a[i]] && w[j-a[i]]<b[i]){
					dp[j]=1;
					w[j]=w[j-a[i]]+1;
					sum++;
				}
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}





多重背包——POJ 1742

标签:

原文地址:http://blog.csdn.net/u013351484/article/details/45317315

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!