码迷,mamicode.com
首页 > 其他好文 > 详细

Gridland ZOJ1037(规律)

时间:2015-04-28 14:07:48      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:

Gridland
Time Limit: 2 Seconds Memory Limit: 65536 KB

Background

For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the "easy" problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the "hard" ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point.


Problem

The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North-South or East-West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 * 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 * 3-Gridland, the shortest tour has length 6.


Figure 7: A traveling-salesman tour in 2 * 3-Gridland.

Input

The first line contains the number of scenarios.

For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.


Output

The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.


Sample Input

2
2 2
2 3


Sample Output

Scenario #1:
4.00

Scenario #2:
6.00

Source: Northwestern Europe 2001

题意:给你n*m的长方形,上有n*m个点,问你能否只经过每个点且必须经过一次,使得能回到起点,且路径最小

只有当n和m都是奇数的时候需要走一个对角线。

#include<bits/stdc++.h>
using namespace std;
const int maxn=100;
int main()
{
    int T;
    scanf("%d",&T);
    for(int i=1;i<=T;i++){
        int n,m;
        scanf("%d%d",&n,&m);
        if((n&1)&&(m&1)){
            printf("Scenario #%d:\n%.2lf\n\n",i,(double)n*m-1+sqrt(2));
        }else{
            printf("Scenario #%d:\n%.2lf\n\n",i,(double)n*m);
        }
    }

    return 0;
}


Gridland ZOJ1037(规律)

标签:

原文地址:http://blog.csdn.net/u013167299/article/details/45334627

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!