标签:algorithm acm poj 二分图 匈牙利算法
COURSES
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 18550 |
|
Accepted: 7310 |
Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the
conditions:
- every student in the committee represents a different course (a student can represent a course if he/she visits that course)
- each course has a representative in the committee
Input
Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:
P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...
CountP StudentP 1 StudentP 2 ... StudentP CountP
The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each
two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.
Output
The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start
of the line.
Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
Sample Output
YES
NO
题意:P门课程,N个学生,问能否从中选出P个学生,使每个学生上不同的课,且每个课程有一个学生。
分析:二分图问题参考该神牛的blog:http://blog.csdn.net/hackbuteer1/article/details/7398008
题目链接:http://poj.org/problem?id=1469
代码清单:
#include<map>
#include<queue>
#include<cmath>
#include<stack>
#include<ctime>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxv = 300 + 5;
int T,P,N,M,Q,ans;
int match[maxv];
bool vis[maxv];
bool graph[maxv][maxv];
bool dfs(int u){ //匈牙利算法
for(int v=1;v<=N;v++){
if(!vis[v]&&graph[u][v]){
vis[v]=true;
if(match[v]==-1 || dfs(match[v])){
match[v]=u;
return true;
}
}
}
return false;
}
int main(){
scanf("%d",&T);
while(T--){
scanf("%d%d",&P,&N);
memset(match,-1,sizeof(match));
memset(graph,false,sizeof(graph));
for(int i=1;i<=P;i++){
scanf("%d",&M);
while(M--){
scanf("%d",&Q);
graph[i][Q]=true;
}
}
ans=0;
for(int i=1;i<=P;i++){
memset(vis,false,sizeof(vis));
if(dfs(i)) ans++;
}
if(ans==P) printf("YES\n");
else printf("NO\n");
}return 0;
}
POJ_1469_COURSES(二分图最大匹配)
标签:algorithm acm poj 二分图 匈牙利算法
原文地址:http://blog.csdn.net/jhgkjhg_ugtdk77/article/details/45336103