码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目4349 Xiao Ming's Hope(找规律)

时间:2015-04-28 18:32:58      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:

Xiao Ming‘s Hope

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1515    Accepted Submission(s): 1015


Problem Description
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn‘t help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn‘t care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn‘t want to let her down. Can you help him?
 

Input
Each line contains a integer n(1<=n<=108)
 

Output
A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).
 

Sample Input
1 2 11
 

Sample Output
2 2 8
 

Author
HIT
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:  4340 4348 4347 4346 4345 
 
题意:求C(n,0),C(n,1),C(n,2)...C(n,n).当中有多少个奇数。
就是n转化为二进制后又多少个1,就是2的多少次方
ac代码
#include<stdio.h>
#include<string.h>
#include<math.h>
int cot(int x)
{
	int ans=0;
	while(x)
	{
		int temp=x%2;
		if(temp)
			ans++;
		x/=2;
	}
	return ans;
}
int qpow(int a,int b)
{
	int ans=1;
	while(b)
	{
		if(b&1)
			ans*=a;
		a*=a;
		b/=2;
	}
	return ans;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",qpow(2,cot(n)));
	}
}


HDOJ 题目4349 Xiao Ming's Hope(找规律)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/45337839

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!