码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3870 Team Formation(位运算)

时间:2015-04-28 21:02:10      阅读:99      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5518


For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{AB}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ithinteger denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

Author: LIN, Xi
Source: The 12th Zhejiang Provincial Collegiate Programming Contest


题意:
给出 n 个数,每次选出两个数,问一共有多少种选法能使得选出的这两个数的异或值比这两个数中最大的那个数还大。
也就是
z = x^y之后,z > max(x, y)。
PS:
对于一个数,如果我们把 x 的二进制表示中的0变成1,0前面的都不变,那么得到的这个新值肯定比x大。
代码如下:
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxn 100017
int a[maxn], c[maxn];
void cal(int m)
{
    int l = 31;
    while(l >= 0)
    {
        if( m & (1<<l))
        {
            c[l]++;
            return ;
        }
        l--;
    }
    return ;
}
int main()
{
    int t;
    int n;
    scanf("%d",&t);
    while(t--)
    {
        memset(c,0,sizeof(c));
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&a[i]);
            cal(a[i]);
        }
        int ans = 0;
        for(int i = 0; i < n; i++)
        {
            int l = 31;
            while(l >= 0)
            {
                if((1<<l) & a[i])//找到最前面那个一的位置
                {
                    break;
                }
                l--;
            }
            while(l >= 0)
            {
                if(!((1<<l) & a[i]))
                {
                    ans+=c[l];
                }
                l--;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}




ZOJ 3870 Team Formation(位运算)

标签:

原文地址:http://blog.csdn.net/u012860063/article/details/45341875

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!