标签:
点击打开杭电1003
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
代码实现:
import java.util.Scanner;
class Main{
public static void main(String[] args){
Scanner sc=new Scanner(System.in);
int t=sc.nextInt();
int k=t;
while(t-->0){
int n=sc.nextInt();
int[] a=new int[n];
int[] dp=new int[n];
for(int i=0;i<n;i++){
a[i]=sc.nextInt();
dp[i]=a[i];
}
int start=1;
int end=1;
for(int i=1;i<n;i++){
dp[i]=Math.max(dp[i],dp[i-1]+a[i]);
}
int max=dp[0],sum=0,j=0;
for(int i=0;i<n;i++){
if(max<dp[i]){
max=dp[i];
end=i+1;
start=j+1;
}
if(dp[i]<0){//当dp[i]<0时起始位置移至i+1
j=i+1;
}
}
System.out.println("Case "+(k-t)+":");
System.out.println(max+" "+start+" "+end);
if(t!=0){
System.out.println();
}
}
}
}
杭电1003(Max Sum) 首次dp
标签:
原文地址:http://blog.csdn.net/u011479875/article/details/45363041