码迷,mamicode.com
首页 > 其他好文 > 详细

as easy problem

时间:2015-04-29 21:45:18      阅读:119      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16297    Accepted Submission(s): 10937


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

Output
for each case, you should the result of y+f(x) on a line.
 

Sample Input
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
19 18 10 -17 -14 -4
 


#include<stdio.h>

main()
{
char c;
int a,b,d,s,n,w,i,q;
scanf("%d",&q);
getchar();
//while(n--)
for(i=0;i<q;i++)
{
scanf("%c%d",&c,&s);
if(c>=‘A‘&&c<=‘Z‘)
{a=c-‘0‘-16;
w=a+s;
//printf("%d\n",w);
}
//continue;
if(c>=‘a‘&&c<=‘z‘)
    {b=c-‘0‘;
    b=b-48;
    a=-b;
   w=a+s;
   //printf("%d\n",w);
//continue;
}
printf("%d\n",w);
getchar();
}
  
return 0;
}

as easy problem

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/45371519

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!