标签:eigrp 综合实验 offset-list
上配置,供参考
INTERNET:
Current configuration : 1192 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname INTERNET
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
ip address 3.3.3.3 255.255.255.255
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface Loopback5
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.14.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.14.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1:
Building configuration...
Current configuration : 2144 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
multilink bundle-name authenticated
!
!
!
key chain net //定义钥匙串
key 1
key-string cisco //定义认证密码
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
ip address 192.168.3.1 255.255.255.0
!
interface Loopback4
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.2.2.1 255.255.255.0
ip authentication mode eigrp 90 md5
ip authentication key-chain eigrp 90 net //在接口上启用密钥认证
ip summary-address eigrp 90 192.168.0.0 255.255.252.0 5 //路由汇总
duplex auto
speed auto
!
interface Serial0/0
ip address 12.1.1.1 255.255.255.0
ip authentication mode eigrp 90 md5
ip authentication key-chain eigrp 90 net //在接口上启用密钥认证
ip summary-address eigrp 90 192.168.0.0 255.255.252.0 5 //路由汇总
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.14.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 90
variance 6 //定义非等价负载均衡值
passive-interface Loopback0 //定义被动接口
passive-interface Loopback1
passive-interface Loopback2
passive-interface Loopback3
passive-interface Loopback4
network 12.1.1.1 0.0.0.0
network 12.2.2.1 0.0.0.0
network 23.1.1.2 0.0.0.0
network 192.168.0.1 0.0.0.0
network 192.168.1.1 0.0.0.0
network 192.168.2.1 0.0.0.0
network 192.168.3.1 0.0.0.0
network 192.168.10.1 0.0.0.0
network 192.168.14.1 0.0.0.0
no auto-summary
!
ip default-network 192.168.14.0 //定义默认网络
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.14.4
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R2:
Current configuration : 1629 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
multilink bundle-name authenticated
!
!
!
key chain cisco
key 1
key-string net
key chain net
key 1
key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.2.2.2 255.255.255.0
ip authentication mode eigrp 90 md5
ip authentication key-chain eigrp 90 net
duplex auto
speed auto
!
interface Serial0/0
ip address 12.1.1.2 255.255.255.0
ip authentication mode eigrp 90 md5
ip authentication key-chain eigrp 90 net
clock rate 2000000
!
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
ip authentication mode eigrp 90 md5
ip authentication key-chain eigrp 90 cisco
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 90
passive-interface Loopback0
offset-list 1 in 30 //偏移列表使用增加30metric值
network 12.1.1.2 0.0.0.0
network 12.2.2.2 0.0.0.0
network 23.1.1.2 0.0.0.0
network 192.168.20.1 0.0.0.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 192.168.30.0 0.0.0.255 //定义ACL抓取30网段路由
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R3:
Current configuration : 1262 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local
!
multilink bundle-name authenticated
!
!
!
key chain cisco
key 1
key-string net
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.30.1 255.255.255.0
!
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
ip authentication mode eigrp 90 md5
ip authentication key-chain eigrp 90 cisco
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
ip authentication mode eigrp 90 md5
ip authentication key-chain eigrp 90 cisco
shutdown
duplex auto
speed auto
!
router eigrp 90
passive-interface Loopback0 //定义环回口为被动接口
network 23.1.1.3 0.0.0.0
network 192.168.30.0
no auto-summary
eigrp stub connected summary //定义stub区域
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
本文出自 “微观世界” 博客,请务必保留此出处http://versun.blog.51cto.com/5629170/1423630
标签:eigrp 综合实验 offset-list
原文地址:http://versun.blog.51cto.com/5629170/1423630