码迷,mamicode.com
首页 > 其他好文 > 详细

BNU14278 Chores(读懂就能做的水)

时间:2015-04-30 18:22:15      阅读:104      评论:0      收藏:0      [点我收藏+]

标签:遍历

Chores

Time Limit: 3000ms
Memory Limit: 30000KB
64-bit integer IO format: %lld      Java class name:Main
Type:
Farmer John‘s family pitches in with the chores during milking, doing all the chores as quickly as possible. At FJ‘s house, some chores cannot be started until others have been completed, e.g., it is impossible to wash the cows until they are in the stalls.

Farmer John has a list of N (3 <= N <= 10,000) chores that must be completed. Each chore requires an integer time (1 <= length of time <= 100) to complete and there may be other chores that must be completed before this chore is started. We will call these prerequisite chores. At least one chore has no prerequisite: the very first one, number 1. Farmer John‘s list of chores is nicely ordered, and chore K (K > 1) can have only chores 1,.K-1 as prerequisites. Write a program that reads a list of chores from 1 to N with associated times and all perquisite chores. Now calculate the shortest time it will take to complete all N chores. Of course, chores that do not depend on each other can be performed simultaneously.

Input

* Line 1: One integer, N

* Lines 2..N+1: N lines, each with several space-separated integers. Line 2 contains chore 1; line 3 contains chore 2, and so on. Each line contains the length of time to complete the chore, the number of the prerequisites, Pi, (0 <= Pi <= 100), and the Pi prerequisites (range 1..N, of course).

Output

A single line with an integer which is the least amount of time required to perform all the chores.

Sample Input

7
5 0
1 1 1
3 1 2
6 1 1
1 2 2 4
8 2 2 4
4 3 3 5 6

Sample Output

23

Hint

[Here is one task schedule:

        Chore 1 starts at time 0, ends at time 5.

        Chore 2 starts at time 5, ends at time 6.

        Chore 3 starts at time 6, ends at time 9.

        Chore 4 starts at time 5, ends at time 11.

        Chore 5 starts at time 11, ends at time 12.

        Chore 6 starts at time 11, ends at time 19.

        Chore 7 starts at time 19, ends at time 23.

]
题意:你要做家务 有n件家务 一些家务需要在其他家务完成的条件下才能执行
每件 有 需要用时间(t) 需要满足的数量n p1~pn
思路:遍历 每次选最大的时间更新第i件家务的完成时间
选择最大的那个时间
#include <bits/stdc++.h>
using namespace std;
int End[10005];
int tp;
int n;
const int inf=0xffffff;

int main()
{
    while(~scanf("%d",&n))
    {
        memset(End,0,sizeof(End));

        int t,np,k;

        for(int i = 0; i < n; i++)
        {
            scanf("%d%d",&t,&np);

            int Mi=0;
            for(int j=1; j<=np; j++)
            {
                scanf("%d",&k);
                Mi=max(Mi,End[k]);//用时间最大的那个
            }
            if(Mi==0)
            {
                End[i+1]=t;
            }
            else
            {
                End[i+1]=t+Mi;
            }
//            printf("%d\n",End[i+1]);
        }

        int ans=0;
        for(int i=1; i<=n; i++)
            ans=max(ans,End[i]);
        printf("%d\n",ans);

    }
}


BNU14278 Chores(读懂就能做的水)

标签:遍历

原文地址:http://blog.csdn.net/u012349696/article/details/45396229

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!