码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM Strange fuction

时间:2015-05-01 12:05:13      阅读:115      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4124    Accepted Submission(s): 2964


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
2 100 200
 

Sample Output
-74.4291 -178.8534
 

Author
Redow
 
二分,很简单。
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
double y;
double A(double x)
{
    return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}
int main()
{

    int T;
    cin>>T;

    while(T--)
    {
        double low=0.0;
        double high=100.0;
        double mid;
        cin>>y;
        if(A(100)<y)
        {
            printf("%.4lf",6*pow(100,7)+8*pow(100,6)+7*pow(100,3)+5*pow(100,2)-y*100);
            continue;
        }

        while(low+1e-8<high)
        {
            mid=(low+high)/2.0;
            
            if(A(mid)>y)
                high=mid;
            else
                low=mid;
        }

        printf("%.4lf\n",6*pow(low,7)+8*pow(low,6)+7*pow(low,3)+5*pow(low,2)-y*low);
    }
    return 0;
}

杭电 HDU ACM Strange fuction

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/45418375

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!