标签:搜索
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
这题可以用深搜,比较容易。
#include<stdio.h>
#include<string.h>
int map[30][30];
int b[100][2],flag,n,m;
int tab[12][2]={0,0,-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};
void dfs(int x,int y,int dep)
{
int i,j,xx,yy;
if(dep==n*m){
flag=1;return;
}
if(flag)return;
for(i=1;i<=8;i++){
xx=x+tab[i][0];yy=y+tab[i][1];
if(xx>=1 && xx<=m && yy>=1 && yy<=n && map[xx][yy]==0){
map[xx][yy]=1;
b[dep+1][0]=xx;
b[dep+1][1]=yy;
dfs(xx,yy,dep+1);
if(flag)break;
map[xx][yy]=0;
}
}
return;
}
int main()
{
int T,i,j,h;
scanf("%d",&T);
for(h=1;h<=T;h++){
scanf("%d%d",&n,&m);
memset(map,0,sizeof(map));
memset(b,0,sizeof(b));
b[1][0]=1;b[1][1]=1;
flag=0;
map[1][1]=1;
dfs(1,1,1);
if(flag==0){
printf("Scenario #%d:\n",h);
printf("impossible\n");
}
else{
printf("Scenario #%d:\n",h);
for(i=1;i<=n*m;i++){
printf("%c%d",b[i][0]+‘A‘-1,b[i][1]);
}
printf("\n");
}
if(h!=T) printf("\n");
}
return 0;
}
poj2488 A Knight's Journey
标签:搜索
原文地址:http://blog.csdn.net/kirito_acmer/article/details/45422859