码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目5087 Revenge of LIS II(第二长LIS)

时间:2015-05-02 09:46:20      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:

Revenge of LIS II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1195    Accepted Submission(s): 400


Problem Description
In computer science, the longest increasing subsequence problem is to find a subsequence of a given sequence in which the subsequence‘s elements are in sorted order, lowest to highest, and in which the subsequence is as long as possible. This subsequence is not necessarily contiguous, or unique.
---Wikipedia

Today, LIS takes revenge on you, again. You mission is not calculating the length of longest increasing subsequence, but the length of the second longest increasing subsequence.
Two subsequence is different if and only they have different length, or have at least one different element index in the same place. And second longest increasing subsequence of sequence S indicates the second largest one while sorting all the increasing subsequences of S by its length.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 100
2. 2 <= N <= 1000
3. 1 <= Ai <= 1 000 000 000
 

Output
For each test case, output the length of the second longest increasing subsequence.
 

Sample Input
3 2 1 1 4 1 2 3 4 5 1 1 2 2 2
 

Sample Output
1 3 2
Hint
For the first sequence, there are two increasing subsequence: [1], [1]. So the length of the second longest increasing subsequence is also 1, same with the length of LIS.
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:  5213 5212 5211 5210 5209 
 


这题太坑了,把思路完全引到了求出LIS,然后判断LIS是否唯一上去了
其实不然, 比如 1 1 2,LIS == 2,但是光这样无法判断出来次大的长度是多少

网上题解是记录每个位置LIS的个数,如果到最后一位LIS只有一个就输出LIS-1,否则去判断LIS上每一个位置上LIS是否唯一,不唯一就输出LIS,否则输出LIS - 1

ac代码

#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
int dp[1010],num[1010];
int a[1010];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,i,j;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			dp[i]=1;
			num[i]=1;
		}
		num[n+1]=1;
		dp[n+1]=1;
		a[n+1]=INF;
		for(i=1;i<=n+1;i++)
		{
			for(j=1;j<i;j++)
			{
				if(a[i]>a[j]&&dp[i]<dp[j]+1)
				{
					dp[i]=dp[j]+1;
					num[i]=1;
				}
				else
				{
					if(a[i]>a[j]&&dp[i]==dp[j]+1)
					{
						num[i]++;
					}
				}
			}
		}
		if(num[n+1]>1)
		{
			printf("%d\n",dp[n+1]-1);
			continue;
		}
		int k=n+1;
		while(k>0&&num[k]==1)
		{
			for(i=k-1;i>=1;i--)
			{
				if(dp[k]==dp[i]+1&&a[k]>a[i])
				{
					break;
				}
			}
			k=i;
		}
		if(k==0)
		{
			printf("%d\n",dp[n+1]-2);
		}
		else
			printf("%d\n",dp[n+1]-1);
	}
}


 

HDOJ 题目5087 Revenge of LIS II(第二长LIS)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/45421281

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!