码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3819 Average Score

时间:2015-05-04 08:43:15      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:入门   zoj   最水题   

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3819


题面:

Average Score

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob‘s. Please calculate the possible range of Bob‘s score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob‘s class and the number of students in the other class respectively.

The next line contains N - 1 integers A1A2, .., AN-1 representing the scores of other students in Bob‘s class.

The last line contains M integers B1B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

Sample Output

4 4
2 4


题意:

该学生在A班会拉低该班成绩,在B班会提高该班成绩,求该学生的成绩能取到的最大值和最小值。因为是整数有点特别,注意下整除的情况就好。


代码:

#include <iostream>
using namespace std;
int main()
{
	int t,n,m,sum1,sum2,tmp,minn,maxx;
	cin>>t;
	while(t--)
	{
		sum1=sum2=0;
	    cin>>n>>m;
		for(int i=1;i<n;i++)
		{
			cin>>tmp;
			sum1+=tmp;
		}
		for(int i=0;i<m;i++)
		{
			cin>>tmp;
			sum2+=tmp;
		}
		if(sum2%m==0)minn=sum2/m+1;
		else minn=(1.0*sum2/m)+1;
		if(sum1%(n-1)==0)maxx=sum1/(n-1)-1;
		else maxx=sum1/(n-1);
		cout<<minn<<" "<<maxx<<endl; 
	}
	return 0;
}


ZOJ 3819 Average Score

标签:入门   zoj   最水题   

原文地址:http://blog.csdn.net/david_jett/article/details/45462903

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!