码迷,mamicode.com
首页 > 其他好文 > 详细

hdu4758AC自动机+状态压缩DP

时间:2015-05-04 10:05:38      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=4758

Problem Description
技术分享

  On the beaming day of 60th anniversary of NJUST, as a military college which was Second Artillery Academy of Harbin Military Engineering Institute before, queue phalanx is a special landscape.
  
  Here is a M*N rectangle, and this one can be divided into M*N squares which are of the same size. As shown in the figure below:
  01--02--03--04
  || || || ||
  05--06--07--08
  || || || ||
  09--10--11--12
  Consequently, we have (M+1)*(N+1) nodes, which are all connected to their adjacent nodes. And actual queue phalanx will go along the edges.
  The ID of the first node,the one in top-left corner,is 1. And the ID increases line by line first ,and then by column in turn ,as shown in the figure above.
  For every node,there are two viable paths:
  (1)go downward, indicated by ‘D‘;
  (2)go right, indicated by ‘R‘;
  The current mission is that, each queue phalanx has to walk from the left-top node No.1 to the right-bottom node whose id is (M+1)*(N+1).
In order to make a more aesthetic marching, each queue phalanx has to conduct two necessary actions. Let‘s define the action:
  An action is started from a node to go for a specified travel mode.
  So, two actions must show up in the way from 1 to (M+1)*(N+1).

  For example, as to a 3*2 rectangle, figure below:
    01--02--03--04
    || || || ||
    05--06--07--08
    || || || ||
    09--10--11--12
  Assume that the two actions are (1)RRD (2)DDR

  As a result , there is only one way : RRDDR. Briefly, you can not find another sequence containing these two strings at the same time.
  If given the N, M and two actions, can you calculate the total ways of walking from node No.1 to the right-bottom node ?
 

Input
  The first line contains a number T,(T is about 100, including 90 small test cases and 10 large ones) denoting the number of the test cases.
  For each test cases,the first line contains two positive integers M and N(For large test cases,1<=M,N<=100, and for small ones 1<=M,N<=40). M denotes the row number and N denotes the column number.
  The next two lines each contains a string which contains only ‘R‘ and ‘D‘. The length of string will not exceed 100. We ensure there are no empty strings and the two strings are different.
 

Output
  For each test cases,print the answer MOD 1000000007 in one line.
 

Sample Input
2 3 2 RRD DDR 3 2 R D
 

Sample Output
1 10

/**
hdu 4758 AC自动机+状态压缩DP
题目大意:给定一个n*m的棋盘,要求从左上角走到右下角,每次只能向下或者向右走。给定两个模式串,问有多少种走法
          满足每一种走法含有这两个模式串作为子串
解题思路:构造自动机,状态压缩包含的子串。
          dp[x][y][i][k] 四维DP,表示R的个数是x,D的个数是y, i是在AC自动机上的节点编号。k 是状态压缩。
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;
const int mod=1e9+7;
int dp[110][110][220][4];
int n,m;
struct Trie
{
    int next[420][2],fail[420],end[420];
    int root,L;
    int change(char ch)
    {
        if(ch=='R')return 0;
        return 1;
    }
    int newnode()
    {
        for(int i=0; i<2; i++)
        {
            next[L][i]=-1;
        }
        end[L++]=0;
        return L-1;
    }
    void init()
    {
        L=0;
        root=newnode();
    }
    void insert(char *buf,int id)
    {
        int len=strlen(buf);
        int now=root;
        for(int i=0; i<len; i++)
        {
            if(next[now][change(buf[i])]==-1)
                next[now][change(buf[i])]=newnode();
            now=next[now][change(buf[i])];
        }
        end[now]|=(1<<id);
    }
    void build()
    {
        queue<int>Q;
        fail[root]=root;
        for(int i=0; i<2; i++)
        {
            if(next[root][i]==-1)
                next[root][i]=root;
            else
            {
                fail[next[root][i]]=root;
                Q.push(next[root][i]);
            }
        }
        while(!Q.empty())
        {
            int now=Q.front();
            Q.pop();
            end[now]|=end[fail[now]];
            for(int i=0; i<2; i++)
            {
                if(next[now][i]==-1)
                {
                    next[now][i]=next[fail[now]][i];
                }
                else
                {
                    fail[next[now][i]]=next[fail[now]][i];
                    Q.push(next[now][i]);
                }
            }
        }
    }
    int solve()
    {
        memset(dp,0,sizeof(dp));
        dp[0][0][0][0]=1;
        for(int x=0; x<=n; x++)
        {
            for(int y=0; y<=m; y++)
            {
                // printf("**\n");
                for(int i=0; i<L; i++)
                {
                    for(int k=0; k<4; k++)
                    {
                        if(dp[x][y][i][k]==0)continue;
                        if(x<n)
                        {
                            int nxt=next[i][0];
                            dp[x+1][y][nxt][k|end[nxt]]+=dp[x][y][i][k];
                            dp[x+1][y][nxt][k|end[nxt]]%=mod;
                        }
                        if(y<m)
                        {
                            int nxt=next[i][1];
                            dp[x][y+1][nxt][k|end[nxt]]+=dp[x][y][i][k];
                            dp[x][y+1][nxt][k|end[nxt]]%=mod;
                        }
                    }
                }
            }
        }
        int ret=0;
        for(int i=0; i<L; i++)
        {
            ret+=dp[n][m][i][3];
            ret%=mod;
        }
        return ret;
    }
} ac;
char str[210];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        ac.init();
        for(int i=0; i<2; i++)
        {
            scanf("%s",str);
            ac.insert(str,i);
        }
        ac.build();
        printf("%d\n",ac.solve());
    }
    return 0;
}


hdu4758AC自动机+状态压缩DP

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/45476405

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!