标签:
Area
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 5248 |
|
Accepted: 2352 |
Description
Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the
area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able
to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are
used. Figure 1 shows the course of a robot around an example area.
Figure 1: Example area.
You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula
he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that
simple formula for you, so your first task is to find the formula yourself.
Input
The first line contains the number of scenarios.
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy?of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair
means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself
except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100
units.
Output
The output for every scenario begins with a line containing 揝cenario #i:? where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers
by two single blanks. Terminate the output for the scenario with a blank line.
Sample Input
2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3
Sample Output
Scenario #1:
0 4 1.0
Scenario #2:
12 16 19.0
Source
Northwestern Europe 2001
ac代码
题目大意:
给一个平面上的简单多边形,求边上的点,多边形内的点,多边形面积。
解题思路:
这个题用了很多知识点:
1、以格子点为顶点的线段,覆盖的点的个数为GCD(dx,dy),其中,dxdy分别为线段横向占的点数和纵向占的点数。如果dx或dy为0,则覆盖的点数为dy或dx。
2、Pick公式:平面上以格子点为顶点的简单多边形的面积=边上的点数/2+内部的点数+1。
3、任意一个多边形的面积等于按顺序求相邻两个点与原点组成的向量的叉积之和。
只要知道了这些,代码很好写,注意细节就行了。
转:http://blog.csdn.net/lin375691011/article/details/17765151
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct s
{
int x,y;
}b[110];
int gcd(int a,int b)
{
if(a<b)
{
int temp=a;
a=b;
b=temp;
}
if(b==0)
return a;
return gcd(b,a%b);
}
int area(struct s a,struct s b)
{
return a.x*b.y-a.y*b.x;
}
int main()
{
int t,cot=0;
scanf("%d",&t);
while(t--)
{
int n;
int i,p=0,a=0;
b[0].x=0;
b[0].y=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d%d",&b[i].x,&b[i].y);
int dx,dy;
dx=abs(b[i].x);
dy=abs(b[i].y);
p+=gcd(dx,dy);
b[i].x+=b[i-1].x;
b[i].y+=b[i-1].y;
a+=area(b[i],b[i-1]);
}
a=abs(a);
printf("Scenario #%d:\n",++cot);
printf("%d %d %.1lf\n",(a-p+2)/2,p,a*0.5);
if(t)
printf("\n");
}
}
POJ题目1265 Area(PICK定理)
标签:
原文地址:http://blog.csdn.net/yu_ch_sh/article/details/45462197