码迷,mamicode.com
首页 > 其他好文 > 详细

0-1背包问题(经典)HDU2602 Bone Collector

时间:2015-05-04 13:18:56      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36479    Accepted Submission(s): 15052


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
技术分享
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

 

Sample Output
14
 

 

Author
Teddy
 

 

Source
 

 AC code:

#include <iostream>
using namespace std;
int main()
{
    int t,n,v,i,j;
    int weight[1005],value[1005],record[1005];
    cin>>t;
    while(t--)
    {
        memset(record,0,sizeof(record));
      cin>>n>>v;
      for(i=0; i<n; i++)
          cin>>value[i];
      for(i=0; i<n; i++)
          cin>>weight[i];
      for(i=0; i<n; i++)
      {
          for(j=v;j>=weight[i]; j--)
          {
              if(record[j-weight[i]]+value[i]>record[j])
                  record[j] = record[j-weight[i]]+value[i];
          }
      }
      cout<<record[v]<<endl;
    }

    return 0;
}

  

0-1背包问题(经典)HDU2602 Bone Collector

标签:

原文地址:http://www.cnblogs.com/lzeffort/p/4475714.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!