码迷,mamicode.com
首页 > 其他好文 > 详细

H-The Cow Lineup(POJ 1989)

时间:2015-05-04 19:52:28      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:

The Cow Lineup
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5367   Accepted: 3196

Description

Farmer John‘s N cows (1 <= N <= 100,000) are lined up in a row.Each cow is labeled with a number in the range 1...K (1 <= K <=10,000) identifying her breed. For example, a line of 14 cows might have these breeds: 
    1 5 3 2 5 1 3 4 4 2 5 1 2 3

Farmer John‘s acute mathematical mind notices all sorts of properties of number sequences like that above. For instance, he notices that the sequence 3 4 1 3 is a subsequence (not necessarily contiguous) of the sequence of breed IDs above. FJ is curious what is the length of the shortest possible sequence he can construct out of numbers in the range 1..K that is NOT a subsequence of the breed IDs of his cows. Help him solve this problem. 

Input

* Line 1: Two integers, N and K 

* Lines 2..N+1: Each line contains a single integer that is the breed ID of a cow. Line 2 describes cow 1; line 3 describes cow 2; and so on. 

Output

* Line 1: The length of the shortest sequence that is not a subsequence of the input 

Sample Input

14 5
1
5
3
2
5
1
3
4
4
2
5
1
2
3

Sample Output

3

Hint

All the single digit ‘sequences‘ appear. Each of the 25 two digit sequences also appears. Of the three digit sequences, the sequence 2, 2, 4 does not appear. 

Source

 
一开始还以为是dp,我都没敢下手啊。。。果然是比较笨。
比较简单的贪心。思路如下:
      因为若是序列包含长度为l的子序列,必然有序列可以划分为l段,每段都包含k个互不相同的数字,则最短的不被包含的子序列长度为l+1。
技术分享
#include <cstdio>
#include <iostream>
#include <sstream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
#define ll long long
#define _cle(m, a) memset(m, a, sizeof(m))
#define repu(i, a, b) for(int i = a; i < (b); i++)
#define MAXN 100005

int num[MAXN];
bool vis[10005];
int main()
{
    int n, k;
    while(~scanf("%d%d", &n, &k))
    {
        repu(i, 0, n) scanf("%d", &num[i]);
        int len = 0, c = 0;
        memset(vis, false, sizeof(vis));
        repu(i, 0, n) {
          if(vis[num[i]]) ;
          else vis[num[i]] = true, c++;
          if(c == k) {
                len++, c = 0;
                 memset(vis, false, sizeof(vis));
          }
        }
        printf("%d\n", len + 1);
    }
    return 0;
}
View Code

 

H-The Cow Lineup(POJ 1989)

标签:

原文地址:http://www.cnblogs.com/sunus/p/4476934.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!