码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 题目1286 Necklace of Beads(Polya定理)

时间:2015-05-05 08:59:13      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:

Necklace of Beads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7061   Accepted: 2942

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 
技术分享

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source

Xi‘an 2002

题目大意:

n个珠子串成一个圆,用三种颜色去涂色。问一共有多少种不同的涂色方法。

不同的涂色方法被定义为:如果这种涂色情况翻转,旋转不与其他情况相同就为不同。


解题思路:

Polya定理模版题。

对于顺时针长度为i的旋转,为pow(3,__gcd(n,i);

对于翻转,当为奇数时,有:n*pow(3.0,n/2+1); 

   当为偶数时,有:n/2*pow(3.0,n/2)+n/2*pow(3.0,n/2+1);


一共有2*n种情况,最后要除以2*n


ac代码

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
int gcd(int a,int b)
{
	if(a<b)
	{
		int temp=a;
		a=b;
		b=temp;
	}
	if(b==0)
	return a;
	return gcd(b,a%b);
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF,n!=-1)
	{
		int i;
		if(n<=0)
		{
			printf("0\n");
			continue;
		}
		__int64 ans=0;
		for(i=1;i<=n;i++)
			ans+=pow(3.0,gcd(i,n));
		if(n&1)
			ans+=n*pow(3.0,n/2+1);
		else
		{
			ans+=n/2*pow(3.0,n/2+1);
			ans+=n/2*pow(3.0,n/2);
		}
		ans/=2*n;
		printf("%I64d\n",ans);
	}
}


POJ 题目1286 Necklace of Beads(Polya定理)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/45487041

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!