标签:
The Embarrassed Cryptographer
Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 563 Accepted Submission(s): 172
Problem Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be
secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users
keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss‘ key.
Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input
set is terminated by a case where K = 0 and L = 0.
Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.
Sample Input
143 10
143 20
667 20
667 30
2573 30
2573 40
0 0
Sample Output
GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31
Source
Recommend
zty | We have carefully selected several similar problems for you:
2300 2308 2301 2305 2306
输入一个大数和一个整数k,然后看看那个大大数能不能整除一个素数,要是可以看看那个素数比k大还是小,要是小就输出BAD,并把那个素数输出出来,否则输出GOOD
ac代码
#include<stdio.h>
#include<string.h>
int is[1000010],prim[10000100],num=0,k;
void fun()
{
int i,j;
for(i=2;i<1000010;i++)
{
if(!is[i])
{
prim[num++]=i;
for(j=i+i;j<1000010;j+=i)
{
is[j]=1;
}
}
}
}
char s[220];
int main()
{
fun();
while(scanf("%s %d",s,&k)!=EOF)
{
if(strcmp(s,"0")==0&&k==0)
break;
int len=strlen(s),i,j,sum;
for(i=0;i<num;i++)
{
int sum=0;
for(j=0;j<len;j++)
{
sum=(sum*10+s[j]-'0')%prim[i];
}
if(sum==0)
break;
}
if(i!=num&&prim[i]<k)
{
printf("BAD %d\n",prim[i]);
}
else
printf("GOOD\n");
}
}
HDOJ 题目2303 The Embarrassed Cryptographer(数学)
标签:
原文地址:http://blog.csdn.net/yu_ch_sh/article/details/45506791