码迷,mamicode.com
首页 > 其他好文 > 详细

E-Eating Together(POJ 3670)

时间:2015-05-05 23:48:38      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:

Eating Together
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5579   Accepted: 2713

Description

The cows are so very silly about their dinner partners. They have organized themselves into three groups (conveniently numbered 1, 2, and 3) that insist upon dining together. The trouble starts when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved Di (1 ≤ Di ≤ 3) indicating her dining group membership. The entire set of N (1 ≤ N ≤ 30,000) cows has lined up for dinner but it‘s easy for anyone to see that they are not grouped by their dinner-partner cards.

FJ‘s job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 111222333 or 333222111 where the cows‘ dining groups are sorted in either ascending or descending order by their dinner cards.

FJ is just as lazy as the next fellow. He‘s curious: what is the absolute mminimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i describes the i-th cow‘s current dining group with a single integer: Di

Output

* Line 1: A single integer representing the minimum number of changes that must be made so that the final sequence of cows is sorted in either ascending or descending order

Sample Input

5
1
3
2
1
1

Sample Output

1

Source

跟F题差不多,就是变成了三个数,变成了升序或降序。。。

技术分享
#include <cstdio>
#include <iostream>
#include <sstream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
#define ll long long
#define _cle(m, a) memset(m, a, sizeof(m))
#define repu(i, a, b) for(int i = a; i < b; i++)
#define MAXN 30005

int d[MAXN][4] = {0};
int cow[MAXN];
int n;
int get_min()
{
    d[1][1] = d[1][2] = d[1][3] = 1;
    d[1][cow[1]] = 0;
    repu(i, 2, n + 1)
      if(cow[i] == 1) {
        d[i][1] = d[i - 1][1];
        d[i][2] = min(d[i - 1][1], d[i - 1][2]) + 1;
        d[i][3] = min(d[i - 1][3], min(d[i - 1][1], d[i - 1][2])) + 1;
      }
      else if(cow[i] == 2) {
        d[i][1] = d[i - 1][1] + 1;
        d[i][2] = min(d[i - 1][1], d[i - 1][2]);
        d[i][3] = min(d[i - 1][3], min(d[i - 1][1], d[i - 1][2])) + 1;
      }
      else {
        d[i][1] = d[i - 1][1] + 1;
        d[i][2] = min(d[i - 1][1], d[i - 1][2]) + 1;
        d[i][3] = min(d[i - 1][3], min(d[i - 1][1], d[i - 1][2]));
      }
    return min(d[n][1], min(d[n][2], d[n][3]));
}
int main()
{
    int minn;
    scanf("%d", &n);
    repu(i, 1, n + 1) scanf("%d", &cow[i]);
    minn = get_min();
    repu(i, 1, n / 2 + 1) swap(cow[i], cow[n - i + 1]);
    minn = min(minn, get_min());
    printf("%d\n", minn);
    return 0;
}
View Code

 

E-Eating Together(POJ 3670)

标签:

原文地址:http://www.cnblogs.com/sunus/p/4480446.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!