码迷,mamicode.com
首页 > 其他好文 > 详细

时钟输出问题

时间:2015-05-06 09:13:25      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

问题:技术分享

样例输入

2
10:37:49
00:00:01

样例输出

1 011001100010100011 001010100101110001 
2 000000000000000001 000000000000000001
 
题意:将时间按照题意竖向和横向输出

回答:
#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std;  
 
int main()  
{  
    int h,m,s,t,i,j,cas = 1;  
    char c1[10],c2[10],c3[10],r1[10],r2[10],r3[10];  
    scanf("%d",&t);  
    while(t--)  
    {  
        memset(c1,‘0‘,sizeof(c1));  
        memset(c2,‘0‘,sizeof(c2));  
        memset(c3,‘0‘,sizeof(c3));  
        scanf("%d:%d:%d",&h,&m,&s);  
        i = 0;  
        while(h)  
        {  
            int r = h%2;  
            c1[i++] = r+‘0‘;  
            h/=2;  
        }  
        i = 0;  
        while(m)  
        {  
            int r = m%2;  
            c2[i++] = r+‘0‘;  
            m/=2;  
        }  
        i = 0;  
        while(s)  
        {  
            int r = s%2;  
            c3[i++] = r+‘0‘;  
            s/=2;  
        }  
        printf("%d ",cas++);  
        for(i = 5;i>=0;i--)  
        printf("%c%c%c",c1[i],c2[i],c3[i]);  
        printf(" ");  
        for(i = 5;i>=0;i--)  
        printf("%c",c1[i]);  
        for(i = 5;i>=0;i--)  
        printf("%c",c2[i]);  
        for(i = 5;i>=0;i--)  
        printf("%c",c3[i]);  
        printf("\n");  
    }  
 
    return 0;  

时钟输出问题

标签:

原文地址:http://www.cnblogs.com/benchao/p/4480854.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!