码迷,mamicode.com
首页 > 其他好文 > 详细

加密(字符串处理)问题

时间:2015-05-06 10:48:48      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

问题:Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

A single data set has 3 components:

Start line - A single line, "START"

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

End line - A single line, "END"

Following the final data set will be a single line, "ENDOFINPUT".
 
Output
For each data set, there will be exactly one line of output. This is the original message by Caesar.
 
Sample Input
START NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX END START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ END START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ END ENDOFINPUT
 
Sample Output
IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
 
回答:
#include<stdio.h>  
#include<string.h>  
#include<map>  
using namespace std;  
map<char,char>mp;  
void init()  
{  
    mp[‘A‘]=‘V‘;mp[‘B‘]=‘W‘;mp[‘C‘]=‘X‘;mp[‘D‘]=‘Y‘;mp[‘E‘]=‘Z‘;mp[‘F‘]=‘A‘;mp[‘G‘]=‘B‘;mp[‘H‘]=‘C‘;  
    mp[‘I‘]=‘D‘;mp[‘J‘]=‘E‘;mp[‘K‘]=‘F‘;mp[‘L‘]=‘G‘;mp[‘M‘]=‘H‘;mp[‘N‘]=‘I‘;mp[‘O‘]=‘J‘;mp[‘P‘]=‘K‘;  
    mp[‘Q‘]=‘L‘;mp[‘R‘]=‘M‘;mp[‘S‘]=‘N‘;mp[‘T‘]=‘O‘;mp[‘U‘]=‘P‘;mp[‘V‘]=‘Q‘;mp[‘W‘]=‘R‘;mp[‘X‘]=‘S‘;  
    mp[‘Y‘]=‘T‘;mp[‘Z‘]=‘U‘;  
}  
 
int main()  
{  
    char s1[10]="START",s2[10]="END",s[10000],s3[20]="ENDOFINPUT";  
    int i,j;  
    map<char,char>::iterator  it;  
    init();  
    while(gets(s))  
    {  
        if(strcmp(s,s3)==0) break;  
        while(gets(s))  
        {  
            if(strcmp(s,"END")==0) {break;}  
            for(i=0;i<strlen(s);i++)  
            {  
                  it=mp.find(s[i]);  
                  if(it==mp.end())  
                      printf("%c",s[i]);  
                  else printf("%c",mp[s[i]]);  
            }  
            printf("\n");  
        }  
    }  
    return 0;  
 
}

加密(字符串处理)问题

标签:

原文地址:http://www.cnblogs.com/benchao/p/4480977.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!