码迷,mamicode.com
首页 > 其他好文 > 详细

Max Sum

时间:2015-05-06 15:14:52      阅读:81      评论:0      收藏:0      [点我收藏+]

标签:杭电   hdoj   1003   max-sum   赫德   

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 168618 Accepted Submission(s): 39345

Problem Description

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6


代码

#include<iostream>
using namespace std;

#define MAXSIZE 100000

void getMax(int arr[], int len, int &maxValue, int &start, int &end)
{
    int current = 0;
    int fromIndex = 1;
    maxValue = -1001;

    for (int i = 1; i <= len; ++i)
    {
        current += arr[i];
        if (current >= maxValue)
        {
            maxValue = current;
            start = fromIndex;
            end = i;
        }
        if (current < 0)
        {
            current = 0;
            fromIndex = i + 1;
        }
    }

}

int main(void)
{
    int T;
    int arr[MAXSIZE] = {};

    cin >> T;
    for (int i = 1; i <= T; ++i)
    {

        int len = 0;
        cin >> len;
        for (int j = 1; j <= len; j++)
        {
            cin >> arr[j];
        }

        int start;
        int end;
        int max;
        getMax(arr, len, max, start, end);
        cout << "Case " << i << ":" << endl;
        cout << max << " " << start << " " << end << endl;;
        if (i < T)
            cout << endl;

        memset(arr, ‘0‘, sizeof(arr));
    }
    //system("pause");
    return 0;
}

Max Sum

标签:杭电   hdoj   1003   max-sum   赫德   

原文地址:http://blog.csdn.net/u013647382/article/details/45534707

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!