码迷,mamicode.com
首页 > 其他好文 > 详细

Saruman's Army(贪心)

时间:2015-05-06 23:06:15      阅读:311      评论:0      收藏:0      [点我收藏+]

标签:


Saruman‘s Army
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep.

 To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among

the troops. Each palantir has a maximum effective range of R units, and must be carried by

some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help

 Saruman take control of Middle Earth by determining the minimum number of palantirs

 needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line

containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000),

and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000).

The next line contains n integers, indicating the positions x1, …, xn of each troop

(where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = ?1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20.

Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering

 troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70.

 Here, note that palantirs must be distributed among troops and are not allowed to “free float.”

Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

代码:

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cstdio>

using namespace std;

struct fun
{
    int l;//区间左边
	int r;//区间右边
	int x;//输入的点
}a[1100];

int ans;
int n, r;
bool cmp(struct fun a, struct fun b)//自定义比较函数,按区间左边从小到大排序
{
   return a.l<b.l;
}

int main()
{
    while(~scanf("%d %d",&r, &n) && r != -1 && n != -1) {
        for(int i = 0; i < n; i++) {
            scanf("%d", &a[i].x);
        }
        for(int i = 0; i < n; i++) {
            a[i].l = a[i].x-r;
            a[i].r = a[i].x+r;
        }
        sort(a, a + n, cmp);
        int l, r;
        ans = 1; l = a[0].x, r = a[0].r;
        for(int i = 1;i < n; i++) {
            if(a[i].l <= l)
                r = a[i].r;
            else if(r < a[i].x) {
                ans++;
                l = a[i].x;
                r = a[i].r;
            }
        }
        cout<< ans <<endl;
    }
    return 0;
}


代码2:

下面这个代码复制一个大牛的.

/*
*  主要是考察贪心算法,首先,对数据进行升序排序,然后,使用贪心算法解决此问题,得到最后的结果。
*/
#include <iostream>
#include <algorithm>

using namespace std;

int solve(int a[], int n,int r)
{
    int ans = 0,i = 0;
    sort(a,a+n);       // 将数组升序
    while(i < n)
    {
        int s = a[i++];     // 一直向右前进直到距s的距离大于r的距离的点
        while(i < n&&a[i] <= s + r) i++;
        int k = a[i-1];     // 一直向右前进直到距k的距离大于r的距离的点
        while(i < n&&a[i] <= k + r) i++;
        ans++;
    }
    return ans;
}
int main(void)
{
    int n,m;
    while(cin>> n >> m,~n&&~m)
    {
        int a[m];
        for(int i = 0; i != m; ++i)
        {
            cin >> a[i];
        }
        cout << solve(a,m,n) << endl;
    }
    return 0;
}



Saruman's Army(贪心)

标签:

原文地址:http://blog.csdn.net/bao_libra/article/details/45540561

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!