题目描述 Description
输入b,p,k的值,编程计算
输入描述 Input Description
b p k
输出描述 Output Description
输出b^p mod k=?
‘=’左右没有空格
样例输入 Sample Input
2 10 9
样例输出 Sample Output
2^10 mod 9=7
题解
这里p的值比较大,不能直接上快速幂。要用到一个公式:
这样就把p放缩到
Code
#include <iostream>
#include <algorithm>
using namespace std;
int b, p, k, phi[1 << 17];
void eulerPhi(int n)//筛出前n个数的欧拉函数,其实只要求出k的欧拉函数值即可
{
phi[1] = 1;
for(int i = 2; i <= n; ++i) if(phi[i] == 0)
for(int j = i; j <= n; j += i)
{
if(phi[j] == 0) phi[j] = j;
phi[j] = phi[j] / i * (i-1);
}
}
int qpow(int a, int n, int m)//对m取模的a的n次方快速幂
{
int ans = 1;
for(int t = a; n != 0; n >>= 1, t = (t % m) * (t % m) % m)
if(n & 1) ans = (ans % m) * (t % m) % m;
return ans;
}
int main()
{
cin >> b >> p >> k;
cout << b << "^" << p << " mod " << k << "=";
eulerPhi(k);
while(p >= 2*phi[k]) p = p % phi[k] + phi[k];//用上述公式缩小p
cout << qpow(b, p, k) << endl;
return 0;
}
原文地址:http://blog.csdn.net/t14t41t/article/details/45564171