码迷,mamicode.com
首页 > 其他好文 > 详细

(STL大法) hdu 3283

时间:2015-05-07 21:55:16      阅读:91      评论:0      收藏:0      [点我收藏+]

标签:

The Next Permutation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 850    Accepted Submission(s): 597


Problem Description
For this problem, you will write a program that takes a (possibly long) string of decimal digits, and outputs the permutation of those decimal digits that has the next larger value (as a decimal number)
than the input number. For example:
123 -> 132
279134399742 -> 279134423799
It is possible that no permutation of the input digits has a larger value. For example, 987.
 

 

Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by up to 80 decimal digits which is the input value.
 

 

Output
For each data set there is one line of output. If there is no larger permutation of the input digits, the output should be the data set number followed by a single space, followed by the string BIGGEST. Ifthere is a solution, the output should be the data set number, a single space and the next larger
permutation of the input digits.
 

 

Sample Input
3 1 123 2 279134399742 3 987
 

 

Sample Output
1 132 2 279134423799 3 BIGGEST
 

 

Source
 
 
STL大法
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<set>
#include<map>
using namespace std;
char s[81];
int main()
{
    int tt,x;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d %s",&x,s);
        int len=strlen(s);
        if(next_permutation(s,s+len))
            printf("%d %s\n",x,s);
        else
            printf("%d BIGGEST\n",x);
    }
    return 0;
}

  

(STL大法) hdu 3283

标签:

原文地址:http://www.cnblogs.com/water-full/p/4485963.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!