码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2082---Terrible Sets(单调栈)

时间:2015-05-07 22:09:58      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:单调栈

Description
Let N be the set of all natural numbers {0 , 1 , 2 , … }, and R be the set of all real numbers. wi, hi for i = 1 … n are some elements in N, and w0 = 0.
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑0<=j<=i-1wj <= x <= ∑0<=j<=iwj}
Again, define set S = {A| A = WH for some W , H ∈ R+ and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.
Your mission now. What is Max(S)?
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.
But for this one, believe me, it’s difficult.

Input
The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w1h1+w2h2+…+wnhn < 109.

Output
Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

Source

一道水题,题面那么难懂…
就是给你一排矩形,求可以形成的最大的矩形面积是多少
单调栈搞定

/*************************************************************************
    > File Name: POJ2082.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年05月07日 星期四 20时11分08秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

static const int N = 50010;
int w[N], h[N];
int r[N], l[N];
int sum[N];
stack <PLL> st;

int main() {
    int n;
    while (~scanf("%d", &n) && n != -1) {
        for (int i = 1; i <= n; ++i) {
            scanf("%d%d", &w[i], &h[i]);
            l[i] = r[i] = i;
        }
        while (!st.empty()) {
            st.pop();
        }
        sum[0] = 0;
        for (int i = 1; i <= n; ++i) {
            sum[i] = sum[i - 1] + w[i];
        }
        for (int i = n; i >= 1; --i) {
            if (st.empty()) {
                st.push(make_pair(h[i], i));
            }
            else {
                while (!st.empty()) {
                    PLL u = st.top();
                    if (u.first <= h[i]) {
                        break;
                    }
                    st.pop();
                    l[u.second] = i + 1;
                }
                st.push(make_pair(h[i], i));
            }
        }
        while (!st.empty()) {
            PLL u = st.top();
            st.pop();
            l[u.second] = 1;
        }
        for (int i = 1; i <= n; ++i) {
            if (st.empty()) {
                st.push(make_pair(h[i], i));
            }
            else {
                while (!st.empty()) {
                    PLL u = st.top();
                    if (u.first <= h[i]) {
                        break;
                    }
                    st.pop();
                    r[u.second] = i - 1;
                }
                st.push(make_pair(h[i], i));
            }
        }
        while (!st.empty()) {
            PLL u = st.top();
            st.pop();
            r[u.second] = n;
        }
        int ans = 0;
        for (int i = 1; i <= n; ++i) {
            int L = l[i];
            int R = r[i];
            ans = max(ans, h[i] * (sum[R] - sum[L - 1]));
        }
        printf("%d\n", ans);
    }
    return 0;
}

POJ2082---Terrible Sets(单调栈)

标签:单调栈

原文地址:http://blog.csdn.net/guard_mine/article/details/45566377

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!