码迷,mamicode.com
首页 > 其他好文 > 详细

O - Treats for the Cows POJ 3186 ( 动态规划+区间 )

时间:2015-05-07 22:12:19      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:


O - Treats for the Cows
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 3186

Description
FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output
Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

题意是:在一个长度为n的区间里,你可以在两端(左端或者右端)取出一个数,这个数乘以他是第几次取出来的。求和的最大值。

dp[ i ][ j ]:表示在区间[ i , j ](j>=i) 里可以获得的最大值。

如果我们从里往外进行计算,找一个数以他作为最后取出来的,由题意可以知道区间[ i , j ]只可能由区间 a[ i ]  + [ i+1,j ]或者 [ i , j-1 ] +a[ j ]组成,结合题意

那么状态转移是dp[ i ][ j ]  = max ( dp[ i ][ j - 1 ] + a[ j ] * ( n - ( j - i ) ,  dp[ i + 1 ][ j ] + a[ i ] * ( n - ( j - i ) ) ); 


#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=2222;
const int inf=999999999;
int dp[maxn][maxn];
int a[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n)){
        for(int i=1;i<=n;i++){
            scanf("%d",a+i);
        }
        for(int i=n;i>=1;i--)//逆序计算因为状态转移,dp[i][j]依赖他的后一个状态dp[i+1][j]
            for(int j=i;j<=n;j++)
                dp[i][j]=max(dp[i+1][j]+a[i]*(n+i-j),dp[i][j-1]+a[j]*(n+i-j));
        printf("%d\n",dp[1][n]);
    }
    return 0;
}













O - Treats for the Cows POJ 3186 ( 动态规划+区间 )

标签:

原文地址:http://blog.csdn.net/u013167299/article/details/45566149

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!