码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2796---Feel Good(前缀和+单调栈维护)

时间:2015-05-07 22:12:48      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:单调栈

Description
Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people’s memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input
The first line of the input contains n - the number of days of Bill’s life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, … an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output
Print the greatest value of some period of Bill’s life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

Source
Northeastern Europe 2005

维护一个递减的单调栈+预处理前缀和

/*************************************************************************
    > File Name: poj2796.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年05月07日 星期四 19时20分20秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

static const int N = 100100;
stack <PLL> st;
int val[N];
LL sum[N];
int l[N];
int r[N];

int main() {
    int n;
    while (~scanf("%d", &n)) {
        sum[0] = 0;
        for (int i = 1; i <= n; ++i) {
            scanf("%d", &val[i]);
            sum[i] = sum[i - 1] + val[i];
            l[i] = r[i] = i;
        }
        while (!st.empty()) {
            st.pop();
        }
        for (int i = n; i >= 1; --i) {
            if (st.empty()) {
                st.push(make_pair(val[i], i));
            }
            else {
                while (!st.empty()) {
                    PLL u = st.top();
                    if (val[i] >= u.first) {
                        break;
                    }
                    st.pop();
                    l[u.second] = i + 1;
                }
                st.push(make_pair(val[i], i));
            }
        }
        while (!st.empty()) {
            PLL u = st.top();
            st.pop();
            l[u.second] = 1;
        }
        for (int i = 1; i <= n; ++i) {
            if (st.empty()) {
                st.push(make_pair(val[i], i));
            }
            else {
                while (!st.empty()) {
                    PLL u = st.top();
                    if (val[i] >= u.first) {
                        break;
                    }
                    st.pop();
                    r[u.second] = i - 1;
                }
                st.push(make_pair(val[i], i));
            }
        }
        while (!st.empty()) {
            PLL u = st.top();
            st.pop();
            r[u.second] = n;
        }
        LL ans = -1;
        int L, R;
        for (int i = 1; i <= n; ++i) {
            int y = r[i];
            int x = l[i];
            if (ans < (sum[y] - sum[x - 1]) * val[i]) {
                ans = (sum[y] - sum[x - 1]) * val[i];
                L = x;
                R = y;
            }
        }
        printf("%lld\n", ans);
        printf("%d %d\n", L, R);
    }
    return 0;
}

POJ2796---Feel Good(前缀和+单调栈维护)

标签:单调栈

原文地址:http://blog.csdn.net/guard_mine/article/details/45565607

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!