码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3250---Bad Hair Day(单调栈)

时间:2015-05-07 22:16:34      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:单调栈

Description

Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

    =

= =
= - = Cows facing right –>
= = =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow’s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow’s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input
Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output
Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

需要知道每个数最多往右扩展到那个位置
维护一个递增的单调栈即可

/*************************************************************************
    > File Name: poj3250.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年05月07日 星期四 18时55分31秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

stack <PLL> st;
int height[80010];
int r[80010];

int main() {
    int n;
    while (~scanf("%d",&n)) {
        for (int i = 1; i <= n; ++i) {
            scanf("%d", &height[i]);
            r[i] = i;
        }
        while (!st.empty()) {
            st.pop();
        }
        for (int i = 1; i <= n; ++i) {
            if (st.empty()) {
                st.push(make_pair(height[i], i));
            }
            else {
                while (!st.empty()) {
                    PLL u = st.top();
                    if (u.first > height[i]) {
                        break;
                    }
                    st.pop();
                    r[u.second] = i - 1;
                }
                st.push(make_pair(height[i], i));
            }
        }
        while (!st.empty()) {
            PLL u = st.top();
            st.pop();
            r[u.second] = n;
        }
        unsigned long long ans = 0;
        for (int i = 1; i <= n; ++i) {
            ans += (r[i] - i);
        }
        printf("%llu\n", ans);
    }
    return 0;
}

POJ3250---Bad Hair Day(单调栈)

标签:单调栈

原文地址:http://blog.csdn.net/guard_mine/article/details/45565129

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!