码迷,mamicode.com
首页 > 其他好文 > 详细

HDU----1253胜利大逃亡 BFS

时间:2015-05-07 22:16:06      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28472    Accepted Submission(s): 10782


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

技术分享

 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
11
这一题是按照6个方向走的:上,下,左,右,前,后。创建一个三维数组记录当前的位置状态。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define N 60
int map[N][N][N];
int vis[N][N][N];
int t,a,b,c,tt;
int dx[] = {0,0,-1,1,0,0};
int dy[] = {0,0,0,0,-1,1};
int dz[] = {-1,1,0,0,0,0};
struct point
{
	int x,y,z,step;
};
int bfs()
{
	if (a - 1 == 0 && b - 1 == 0 && c - 1 == 0)//如果出口位置与入口相同,直接返回0.
		return 0;
	point temp, head, tt;
	queue<point>q;
	while (!q.empty())
		q.pop();
	vis[0][0][0] = 1;
	temp.x = 0; temp.y = 0; temp.z = 0; temp.step = 0;
	q.push(temp);
	while (!q.empty())
	{
		head = q.front();
		q.pop();
		for (int i = 0; i < 6; i++)
		{
			tt.x = head.x + dx[i];
			tt.y = head.y + dy[i];
			tt.z = head.z + dz[i];
			if (tt.x < 0 || tt.y < 0 || tt.z < 0 || tt.x >= a || tt.y >= b || tt.z >= c || vis[tt.x][tt.y][tt.z]||map[tt.x][tt.y][tt.z])
				continue;
			tt.step = head.step + 1;
			vis[tt.x][tt.y][tt.z] = 1;
			if (tt.x == a - 1 && tt.y == b - 1 && tt.z == c - 1)
				return tt.step;
			q.push(tt);
		}
	}
	return (-1);//如果找不到出口就返回-1.
}
int main()
{	
	scanf("%d", &t);
	while (t--)
	{
		memset(vis, 0, sizeof(vis));
		scanf("%d%d%d%d", &a, &b, &c, &tt);
		for (int i = 0; i < a; i++)
		{
			for (int j = 0; j < b; j++)
			{
				for (int k = 0; k < c; k++)
				{
					scanf("%d", &map[i][j][k]);
				}
			}
		}
		int ans = bfs();
		if (ans<0 || ans>tt)//返回值小于零找不到出口,大于魔王的时间都不能逃脱.
			printf("-1\n");
		else
			printf("%d\n", ans);
	}
	return 0;
}

HDU----1253胜利大逃亡 BFS

标签:

原文地址:http://blog.csdn.net/qq_24489717/article/details/45564989

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!