码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1506---Largest Rectangle in a Histogram(单调栈)

时间:2015-05-07 22:16:16      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:单调栈

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Source
University of Ulm Local Contest 2003

Recommend
LL | We have carefully selected several similar problems for you: 1505 1058 2870 1864 2830

Statistic | Submit | Discuss | Note

单调栈

/*************************************************************************
    > File Name: hdu1506.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年05月07日 星期四 18时25分41秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

stack <PLL> st;
int height[100110];
int l[100110];
int r[100110];

int main() {
    int n;
    while (~scanf("%d", &n), n) {
        for (int i = 1; i <= n; ++i) {
            scanf("%d", &height[i]);
            l[i] = r[i] = i;
        }
        while (!st.empty()) {
            st.pop();
        }
        for (int i = n; i >= 1; --i) {
            if (st.empty()) {
                st.push(make_pair(height[i], i));
            }
            else {
                while (!st.empty()) {
                    PLL u = st.top();
                    if (u.first <= height[i]) {
                        break;
                    }
                    st.pop();
                    l[u.second] = i + 1;
                }
                st.push(make_pair(height[i], i));
            }
        }
        while (!st.empty()) {
            PLL u = st.top();
            st.pop();
            l[u.second] = 1;
        }
        for (int i = 1; i <= n; ++i) {
            if (st.empty()) {
                st.push(make_pair(height[i], i));
            }
            else {
                while (!st.empty()) {
                    PLL u = st.top();
                    if (u.first <= height[i]) {
                         break;
                    }
                    st.pop();
                    r[u.second] = i - 1;
                }
                st.push(make_pair(height[i], i));
            }
        }
        while (!st.empty()) {
            PLL u = st.top();
            st.pop();
            r[u.second] = n;
        }
        LL ans = 0;
        for (int i = 1; i <= n; ++i) {
            ans = max(ans, (LL)height[i] * (r[i] - l[i] + 1));
        }
        printf("%lld\n", ans);
    }
    return 0;
}

hdu1506---Largest Rectangle in a Histogram(单调栈)

标签:单调栈

原文地址:http://blog.csdn.net/guard_mine/article/details/45564985

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!