码迷,mamicode.com
首页 > 其他好文 > 详细

[swustoj 1094] 中位数

时间:2015-05-07 23:31:24      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:

中位数(1094)

问题描述

中位数(又称中值,英语:Median),统计学中的专有名词,代表一个样本、种群或概率分布中的一个数值,其可将数值集合划分为相等的上下两部分。对于有限的数集,可以通过把所有观察值高低排序后找出正中间的一个作为中位数。如果观察值有偶数个,则中位数不唯一,通常取最中间的两个数值的平均数作为中位数。

输入

多组输入

第一行:一个正整数N (0<N<1000000) 第二行:N个正整数。(0=<A[i]<2^30)

输出

每组数据先输出”Case X:”,X表示测试数据的编号,从1开始。

第二行输出N个数,第i个数对应数组前i个值的中位数。(精确到小数点后一位)

样例输入

5
1 2 3 4 5
6
2 5 4 8 7 4

样例输出

Case 1:
1.0 1.5 2.0 2.5 3.0
Case 2:
2.0 3.5 4.0 4.5 5.0 4.5

简单线段树

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define N 1000010

int n;
int a[N];
int b[N];
int c[N];
int cnt[N<<2];

void pushup(int rt)
{
    cnt[rt]=cnt[rt<<1]+cnt[rt<<1|1];
}
void build(int n)
{
    memset(cnt,0,sizeof(cnt));
}
void update(int l,int r,int rt,int pos)
{
    if(l==r)
    {
        cnt[rt]++;
        return;
    }
    int m=(l+r)>>1;
    if(pos<=m) update(l,m,rt<<1,pos);
    else update(m+1,r,rt<<1|1,pos);
    pushup(rt);
}
int query(int l,int r,int rt,int c)
{
    if(l==r) return l;
    int m=(l+r)>>1;
    if(c<=cnt[rt<<1]) query(l,m,rt<<1,c);
    else return query(m+1,r,rt<<1|1,c-cnt[rt<<1]);
}
int main()
{
    int iCase=1;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[i]=a[i];
        }
        sort(b+1,b+n+1);
        for(int i=1;i<=n;i++)
        {
            int t=a[i];
            a[i]=lower_bound(b+1,b+n+1,a[i])-b;
            c[a[i]]=t;
        }
        build(n);
        printf("Case %d:\r\n",iCase++);
        for(int i=1;i<=n;i++)
        {
            if(i-1) printf(" ");
            update(1,n,1,a[i]);
            if(i&1) printf("%.1f",double(c[query(1,n,1,i/2+1)]));
            else printf("%.1f",(c[query(1,n,1,i/2)]+c[query(1,n,1,i/2+1)])/2.0);
        }
        printf("\r\n");
    }
    return 0;
}

 

[swustoj 1094] 中位数

标签:

原文地址:http://www.cnblogs.com/hate13/p/4486373.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!