标签:csuoj 离线并查集
1601: War
Time Limit: 1 Sec Memory Limit:
128 MB
Submit: 130 Solved: 38
[Submit][Status][Web
Board]
Description
AME decided to destroy CH’s country. In CH’ country, There are N villages, which are numbered from 1 to N. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between
A and C, and C and B are connected. To defend the country from the attack of AME, CH has decided to build some roads between some villages. Let us say that two villages belong to the same garrison area if they are connected.
Now AME has already worked out the overall plan including which road and in which order would be attacked and destroyed. CH wants to know the number of garrison areas in his country after each of AME’s attack.
Input
The first line contains two integers N and M — the number of villages and roads, (2 ≤ N ≤ 100000; 1 ≤ M ≤ 100000). Each of the next M lines contains two different integers u, v (1<=u, v<=N)—which means there is a road between u and v. The next line contains
an integer Q which denotes the quantity of roads AME wants to destroy (1 ≤ Q ≤ M). The last line contains a series of numbers each of which denoting a road as its order of appearance — different integers separated by spaces.
Output
Output Q integers — the number of garrison areas in CH’s country after each of AME‘s attack. Each pair of numbers are separated by a single space.
Sample Input
3 1
1 2
1
1
4 4
1 2
2 3
1 3
3 4
3
2 4 3
Sample Output
3
1 2 3
题目链接:http://acm.csu.edu.cn/OnlineJudge/problem.php?id=1601
题目大意:n个点m条边(边1,边2...边m),q个要摧毁的边,求按顺序每摧毁一条边后图中连通块的个数
题目分析:离线并查集,反向加边,先将q条路全部摧毁后的连通块个数求出来,然后加边即可,每加一条边,若两点不在同一连通块中,则合并且连通块个数减1
#include <cstdio>
#include <cstring>
int const MAX = 1e5 + 5;
int fa[MAX], n, m;
int x[MAX], y[MAX], r[MAX];
int ans, res[MAX];
bool vis[MAX];
void UF_set()
{
for(int i = 0; i <= n; i++)
fa[i] = i;
}
int Find(int x)
{
return x == fa[x] ? x : fa[x] = Find(fa[x]);
}
void Union(int a, int b)
{
int r1 = Find(a);
int r2 = Find(b);
if(r1 != r2)
{
fa[r2] = r1;
ans --;
}
}
int main()
{
while(scanf("%d %d", &n, &m) != EOF)
{
UF_set();
ans = n;
memset(vis, false, sizeof(vis));
for(int i = 1; i <= m; i++)
scanf("%d %d", &x[i], &y[i]);
int q;
scanf("%d", &q);
for(int i = 1; i <= q; i++)
{
scanf("%d", &r[i]);
vis[r[i]] = true;
}
for(int i = 1; i <= m; i++)
if(!vis[i])
Union(x[i], y[i]);
for(int i = q; i >= 1; i--)
{
res[i] = ans;
Union(x[r[i]], y[r[i]]);
}
for(int i = 1; i < q; i++)
printf("%d ", res[i]);
printf("%d\n", res[q]);
}
}
CSUOJ 1601 War (离线并查集求连通块个数)
标签:csuoj 离线并查集
原文地址:http://blog.csdn.net/tc_to_top/article/details/45567797